PDAL 1.6.0 packaged for Fedora including vertical datums and grids

Cologne city shown as colorized 3D point cloud (data source: openNRW Germany)In order to simplify the installation of the latest PDAL release (Point Data Abstraction Library, http://www.pdal.io/, version 1.6.0) on Fedora, I have created an updated set of RPM packages now including vertical datums and grids (.gtx files from here).

The installation is as simple as this (the repository is located at Fedora’s COPR):

# enable extra repos to satisfy dependencies
sudo dnf copr enable neteler/pdal-hexer
sudo dnf copr enable neteler/points2grid

# install dependencies
sudo dnf install hexer
sudo dnf install points2grid

# enable and install PDAL
sudo dnf copr enable neteler/pdal
sudo dnf install PDAL PDAL-devel PDAL-vdatums

# run PDAL:
pdal-config --version
pdal --help

Enjoy!

This entry was posted in Fedora, FOSS4G, FOSSGIS, GFOSS, Lidar, PDAL on by .

About neteler

Markus Neteler , a founding-member of the FOSSGIS.de (D-A-CH), GFOSS.it (Italy), and the Open Source Geospatial Foundation (OSGeo), was head of the GIS and Remote Sensing Unit at the Research and Innovation Centre of the Fondazione Edmund Mach, Trento, Italy from 2008-2016. Since then he is CEO of mundialis company located in Bonn, Germany, a startup specialized in open source development and massive data processing. He is author of several books and chapters on GRASS and various papers on GIS applications. Being passionate about Open Source GIS, he became a GRASS GIS user in 1993 and a developer in 1997, coordinating its development since then.

13 thoughts on “PDAL 1.6.0 packaged for Fedora including vertical datums and grids

  1. Pingback: PDAL 1.6.0 packaged for Fedora including vertical datums and grids – GeoNe.ws

  2. Charlie

    Hi, when I try to install PDAL on Fedora 27 I get the following error:

    “Error:
    Problem: package PDAL-1.6.0-1.fc27.x86_64 requires libpdal_base.so.5()(64bit), but none of the providers can be installed
    – conflicting requests
    – nothing provides pkgconfig(geos) needed by PDAL-libs-1.6.0-1.fc27.x86_64”

    Do you have any idea how to get around this?
    Thanks!

    Reply
        1. Charlie

          I tried again although now I have set of slightly different error messages that still seem to hinge on nothing providing pkconfig(geos)…


          Error:
          Problem 1: conflicting requests
          – package PDAL-devel-1.6.0-1.fc27.x86_64 requires PDAL-libs(x86-64) = 1.6.0-1.fc27, but none of the providers can be installed
          – nothing provides pkgconfig(geos) needed by PDAL-libs-1.6.0-1.fc27.x86_64
          Problem 2: conflicting requests
          – package PDAL-1.6.0-1.fc27.x86_64 requires libpdal_base.so.5()(64bit), but none of the providers can be installed
          – nothing provides pkgconfig(geos) needed by PDAL-libs-1.6.0-1.fc27.x86_64
          Problem 3: conflicting requests
          – package PDAL-vdatums-1.6.0-1.fc27.x86_64 requires PDAL = 1.6.0-1.fc27, but none of the providers can be installed
          – package PDAL-1.6.0-1.fc27.x86_64 requires libpdal_base.so.5()(64bit), but none of the providers can be installed
          – nothing provides pkgconfig(geos) needed by PDAL-libs-1.6.0-1.fc27.x86_64

          Thank you for your help!!

          Reply
  3. Reza S.

    Hello Mr. Neteler —

    Could you confirm if this error has been resolved with F27.
    I’m working on LiDAR data processing and found pdal parser essential to our research.

    Reply
  4. neteler Post author

    Hi, I have finally run into the issue myself! To me it looks like an outdated libboost_filesystem.so being present on the COPR platform.

    A dirty hack (workaround) is the following

    sudo ln -s /usr/lib64/libboost_filesystem.so.1.63.0 /usr/lib64/libboost_filesystem.so.1.60.0
    sudo ldconfig

    Then all appears to work fine. I hope that the problem disappears in the near future on COPR.

    Reply
  5. Euan de Kock

    Hi,

    I am getting the same error on Fedora 30.

    I have tried linking the libboost library as suggested above, but to no avail.

    # cd /usr/lib64; ln -s libboost_filesystem.so.1.69.0 libboost_filesystem.so.1.60.0

    # dnf install PDAL-devel
    Last metadata expiration check: 0:11:49 ago on Fri 26 Jul 2019 10:40:57 AM AWST.
    Error:
    Problem: conflicting requests
    – nothing provides pkgconfig(geos) needed by PDAL-devel-1.8.0-2.fc30.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)

    Reply
    1. Euan de Kock

      Just adding to this: The reason I am installing the PDAL-devel package is that the pip install of the python package “pip install pdal” requires that the PDAL header files be available during the build.

      I specifically don’t use the conda packaging as it plays havoc under Linux with the existing python installation.

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

I confirm